Summary

This problem may be caused either by OBRM backup service or WMI (Windows Management Instrumentation) problems. Also, the problem may be caused by the precedence of starting these services. WMI service should always start before OBRM backup service.

What to check

  1. Check if service “Offsite Online Backup Service” (SAgentservice) runs under the proper user credentials. These should be either Local System credentials or credentials of a local administrator.

    • press Win+R, enter services.msc, and then click OK.

    • locate “Offsite Online Backup service” and click Properties (or check column “Log On As”)

  2. Check if service “Windows Management Instrumentation” is running (in Services window opened at step 1):

    If the service isn’t running, start it.

  3. Run the attached tool “ManagementEventWatcherTester” as Administrator to check if the WMI service works without issues. (download link)

    It’ll display a command line window with text “Started…”

    • open Notepad, and the text “processStartEvent_EventArrived” should appear:

    • close Notepad and the application will show processStopEvent_EventArrived.

      If the application does not show the above messages, there may be problems with WMI service on the machine.

      If everything works as described above, the problem may be caused by the precedence of starting these services. WMI service should always start before Offsite Online Backup Service.

  4. To change precedence (set dependency) of the starting services:

    1. Open the Command Prompt as administrator.

    2. Enter _sc config "sagentservice" depend= winmgmt, and then press Enter.

      The following message should appear: SC ChangeServiceConfig SUCCESS.

    3. More information is provided here.

  5. Restart the computer, and then check OBRM logs (SAgent.Service.log) if SAgentService doesn’t return any errors.